hate these ads?, log in or register to hide them
Page 2 of 2 FirstFirst 12
Results 21 to 27 of 27

Thread: Help figuring out NVME drive/mainboard issue (no boot no good)

  1. #21
    מלך יהודים Zeekar's Avatar
    Join Date
    April 10, 2011
    Posts
    15,792
    Always the same display Duo? Maybe it had a fucked DP connection?


    

  2. #22

    Join Date
    April 9, 2011
    Location
    Chichester, UK
    Posts
    2,123
    Quote Originally Posted by Zeekar View Post
    Always the same display Duo? Maybe it had a fucked DP connection?
    Yeah it was the monitor that was damaging the cable (I dont know how) and then that cable could then (in a different pc/monitor combo) cause the pci-e lanes not to work. Just magic

    Spent so much on cables to that one

    I still have the monitor lol

  3. #23
    GeromeDoutrande's Avatar
    Join Date
    April 10, 2011
    Location
    Fakefrenchistan
    Posts
    3,933
    Got myself a replacement NVME drive and reinstalled Windows. Everything appears to be working fine again. Have started RMA proceedings for the old broken drive.

    Thank you all for your help!

  4. #24
    Daneel Trevize's Avatar
    Join Date
    April 10, 2011
    Location
    T L A
    Posts
    13,015
    Corsair MP510
    The 2018 Force series? What size? Name & shame...
    Quote Originally Posted by QuackBot View Post
    Idk about that, and i'm fucking stupid.

  5. #25
    GeromeDoutrande's Avatar
    Join Date
    April 10, 2011
    Location
    Fakefrenchistan
    Posts
    3,933
    Quote Originally Posted by Daneel Trevize View Post
    Corsair MP510
    The 2018 Force series? What size? Name & shame...
    A 960GB one bought 2019

  6. #26

    Join Date
    April 18, 2011
    Posts
    3,836
    Quote Originally Posted by GeromeDoutrande View Post
    Quote Originally Posted by Daneel Trevize View Post
    Corsair MP510
    The 2018 Force series? What size? Name & shame...
    A 960GB one bought 2019
    ... That's the one I have..

  7. #27
    GeromeDoutrande's Avatar
    Join Date
    April 10, 2011
    Location
    Fakefrenchistan
    Posts
    3,933
    Just to complete this: I did get a free replacement drive from Corsair (new, same model), took about two weeks which I find okay given that I reported the fault directly after the holiday break, service was generally good (didn't have to pay for shipping the drive back etc.).

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •